Reply to topic  [ 4 posts ] 
Dependancy broken in imutil.i 
Author Message

Joined: Mon Feb 18, 2008 9:41 am
Posts: 9
Post Dependancy broken in imutil.i
Hello

Just to mention a problem I had with imutil:
> a= spline2(img,4)

ERROR (spline2) attempt to call non-function or index non-array
LINE: 484 FILE: /usr/lib/yorick/i0/imutil.i
To enter debug mode, type <RETURN> now (then dbexit to get out)

It cannot find the function "indices".

I had to fix the problem by adding:
#include "util_fr.i"

Maybe Francois can have a look.

Cheers,
Sylvestre


Thu Dec 03, 2009 10:45 am
Profile WWW
Yorick Master

Joined: Sun Sep 26, 2004 10:33 am
Posts: 150
Location: Australia
Post 
Salut,

Oops. long time I haven't browsed these forums (vacation, travel & Xmas!).
Thanks. That's indeed the solution, and doesn't add a dependency as yutils (which includes util_fr.i) is already a dependency. Will patch the next release.


Wed Dec 30, 2009 9:27 am
Profile WWW

Joined: Mon Feb 18, 2008 9:41 am
Posts: 9
Post 
Ok. Cool.

Happy New Year.


Tue Jan 19, 2010 9:00 am
Profile WWW
Yorick Master

Joined: Tue Mar 07, 2006 10:31 pm
Posts: 125
Location: Meudon, France
Post 
Hi Fran├žois,

This also means the indices function must be missing from the autoloads. Can you add it there ?

Regards, Thibaut.


Tue Feb 02, 2010 9:25 am
Profile WWW
Display posts from previous:  Sort by  
Reply to topic   [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.